Forums on Intune, SCCM, and Windows 11

Welcome to the forums. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your topics and posts, as well as connect with other members through your own private inbox!

PENDING Content Distribution is Failing to DPs after Windows Server In-Place Upgrade on Primary Site Server

Messages
6
Solutions
1
Reaction score
0
Points
1
Hello all,

I'm hitting a wall on troubleshooting an issue I've discovered in my environment. I have a smaller environment, with 1 primary site server that acts as MP and local DP, and 4 other DPs for other locations. A few weeks ago, I performed a Windows IPU on the primary site server to upgrade from Server 2016 to Server 2019. Since upgrading, it appears content is no longer distributing to the DPs. I only just noticed last week because patch tuesday updates were not distributing. When looking at the status messages for SMS_DISTRIBUTION_MANAGER in Monritoring > Component status, I'm see "failed to connect to DP" for all 4 (Screenshot attached). When I attempt to re-distribute the monthly patch deployment package, I reviewed the Distmgr.log file and see "CWmi::Connect() failed to connect to \\GRR-SCCM.domain.com\root\CIMv2. Error = 0x800706BA" (screenshot also attached). It also says it failed to find a valid drive after that, but I suspect that may just be caused by the previous error? In any event, I double checked and there should be plenty of drive space on the drive it has content distributed to. I can also confirm that the primary site computer account is local admin on all DPs as well, and I have turned off Windows Firewall temporarily on both sides (primary site and DP), and it still happens so I should be able to rule those two causes out. Anyone have any thoughts on what is causing this that I might be missing?
 

Attachments

  • component status.png
    component status.png
    26.9 KB · Views: 6
  • distmgr.log.png
    distmgr.log.png
    36.7 KB · Views: 7
Solution
Issue resolved:

I marked up this as a lost cause and tried everything, and was about to spin up a new VM and perform a backup+restore. But right before I did that, I figured since I mentally marked this machine down as a lost cause, I decided to do another in-place upgrade from 2019 to 2022, and who would guess... It's working now.
Doing some more testing and I found something interesting. Whenever I test remote WMI using wbemtest and attempting to connect to a DP namespace FROM the primary server, I receive an access denied error. But, testing the opposite direction or testing to other devices (so long as it's not originating from the primary server), it works. This sounds similar to the DCOM hardening that occurred a few years ago where I found this reddit post of someone experiencing nearly the same thing:


Although I would imagine this wouldn't still be the case for my instance because I patch servers monthly. This is just so confusing.
 
Issue resolved:

I marked up this as a lost cause and tried everything, and was about to spin up a new VM and perform a backup+restore. But right before I did that, I figured since I mentally marked this machine down as a lost cause, I decided to do another in-place upgrade from 2019 to 2022, and who would guess... It's working now.
 
Solution
Back
Top