SOLVED SCCM high CPU usage every 10 minutes

Status
Not open for further replies.

sccmallday

Member
5
0
1
I have been working on this issue for quite a few weeks now with no resolution yet. We have upgraded to SCCM Version 1702 with a fresh install of on Server 2016. As you can see from the attached Vsphere screenshot since installing WSUS the CPU maxes every 10 minutes or so. SCCM console is unusable during this period. The high CPU is stemming from the WSUS pool, which I have set to throttle to 50%, but that does not appear to be working. I also set the private memory limit to 4GB, which did not make any difference in cpu usage. I believe another issue related to this is the 0x80072EE2 error when automatically deploying Windows updates. Clients can talk to SCCM and deploy applications normally, but windows updates all error out. Any help would be greatly appreciated as our team is at our wits end between these two issues.
 

Attachments

  • sccm high cpu.PNG
    sccm high cpu.PNG
    81.3 KB · Views: 24
Solution
What I have done is change the WSUS website to port 8080 and made the same changes in SCCM. Doing this produced the same 0x80072EE2 error when deploying updates. I went back and changed the port to 8530 again and waited for everything to synchronize. Once I did that THEN the updates started working again without explanation. The only thing I can think is that something was not registered correctly on the 8530 port, and changing it once then changing it back re-registered it. In any case, it looks like it is working as intended now, thank you for your assistance.
OP
S

sccmallday

Member
5
0
1
Are you sure it's WSUS ?. I guess it might be SQL or IIS. Worth checking again and if possible attach the screenshot of processes running under task manager.
Thank you for your response, I should have been more clear. The high CPU is related the the WsusPool in IIS. I have dedicated about 6GB to the private memory limit and that seems to have helped, between that and the CPU throttle to 55% it now stays between 75 and 80% which is acceptable. The bigger issue I have here is the 0x80072EE2 error when automatically deploying windows updates. I have attached screenshots of logs. Windows firewall is disabled on both server and clients and we do not use a proxy.
 

Attachments

  • iis worker process.PNG
    iis worker process.PNG
    10.5 KB · Views: 25
  • iis wsus pool.PNG
    iis wsus pool.PNG
    50.6 KB · Views: 22
  • update error code.PNG
    update error code.PNG
    97.9 KB · Views: 21
  • 80072ee2 error.PNG
    80072ee2 error.PNG
    53.3 KB · Views: 18
OP
S

sccmallday

Member
5
0
1
I have uninstalled both the WSUS role and the SUP, and added them back to the server. I also added more memory and set the private memory limit to 8GB, which helped with the high CPU usage a bit. Server is able to synchronize and download updates without any issues. I still am getting the 0x80072EE2 error when deploying windows updates to clients however, no clients are getting updates. OS is server 2016 and SCCM build is 8498.
 

Prajwal Desai

Forum Owner
Staff member
3,636
441
183
If you have sorted out the high CPU usage issue it's great. Coming to " 0x80072EE2 error when deploying windows updates to clients " - Error 0x80072ee2 translates to ERROR_INTERNET_TIMEOUT. Since the updates are already downloaded, I would suggest you to check if there are connectivity issues between the clients and DP. It could be an issue with Firewall, security appliance etc. Similar issue is resolved here. - https://prajwaldesai.com/community/...2-while-pushing-updates-to-2008r2-server.315/
 
OP
S

sccmallday

Member
5
0
1
What I have done is change the WSUS website to port 8080 and made the same changes in SCCM. Doing this produced the same 0x80072EE2 error when deploying updates. I went back and changed the port to 8530 again and waited for everything to synchronize. Once I did that THEN the updates started working again without explanation. The only thing I can think is that something was not registered correctly on the 8530 port, and changing it once then changing it back re-registered it. In any case, it looks like it is working as intended now, thank you for your assistance.
 
Solution

Prajwal Desai

Forum Owner
Staff member
3,636
441
183
That's great. So you don't see the error 0x80072ee2 anymore ?. I was guessing it could have been some connectivity issues between clients and DP.
 
OP
S

sccmallday

Member
5
0
1
I have been fighting this error for months now because that is exactly what it means. I even built a new Server 2016 which had that error as well. It seems to be one of those things I can't explain but as long as it's working then I'm ok with it.
 
Status
Not open for further replies.

Forum statistics

Threads
4,383
Messages
17,189
Members
8,865
Latest member
ChloeY